Annonce

>>> Bienvenue sur codelab! >>> Première visite ? >>> quelques mots sur codelab //// partage de liens //// une carte des membres//// (apéros) codelab


#16 2014-10-26 14:16:00 Re : v4l2 FFMPEG loopback et autres petits soucis

sakramh
membre
Lieu: clichy-sous-bois
Date d'inscription: 2008-12-02
Messages: 828
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



pas obligatoire de passer par jack si pd fonctionne bien sur alsa . simplifie le souci de compilation ffmpeg avec le support jack .


le code est l'alchimie de l'âge du silicium

Hors ligne

 

#17 2014-11-01 12:42:13 Re : v4l2 FFMPEG loopback et autres petits soucis

sakramh
membre
Lieu: clichy-sous-bois
Date d'inscription: 2008-12-02
Messages: 828
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



ha oui pas mal la rotation avec [pix_record] ! mad sad  ai vérifié avec un mplayer (-flip) -tv ...
d'où un [pix_flip] devrait suffire  (sur ma machine si j'ouvre direct l'aide à partir du menu Aide >>> crash de pd !!!! pas de crash si j'ouvre l'aide à partir de l'objet )

Dernière modification par sakramh (2014-11-01 12:42:43)


le code est l'alchimie de l'âge du silicium

Hors ligne

 

#18 2014-11-06 22:25:15 Re : v4l2 FFMPEG loopback et autres petits soucis

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 178

Re: v4l2 FFMPEG loopback et autres petits soucis



Olivier a écrit:

citation :

Le retournement ne fonctionne pas si je n'utilise pas [pix_snap]

??!!
Je ne comprends pas... hmm

Oui, c'est normal, je me suis trompé big_smile Ca fonctionne avec ou sans [pix_snap] smile

Et [pix_flip] fonctionne bien tongue

Par ailleurs j'essai de compiler une version statique, avec jack, de ffmpeg, mais je n'y arrive pas encore...

Dernière modification par Tepaze (2014-11-06 22:27:28)

Hors ligne

 

#19 2014-11-06 23:13:42 Re : v4l2 FFMPEG loopback et autres petits soucis

sakramh
membre
Lieu: clichy-sous-bois
Date d'inscription: 2008-12-02
Messages: 828
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



j'imagine que çà a été visité : http://doc.ubuntu-fr.org/tutoriel/comme … ler_ffmpeg
par ailleurs un patch de ce genre consomme la moitié de celui avec [pix_snap] (respectivement 7% et 15% d'un coeur d'un quadri à 2,83 ghz ).
http://codelab.fr/up/capt.png
le [pix_flip] peut être connecté direct à la sortie du [pix_video]

Dernière modification par sakramh (2014-11-06 23:17:00)


le code est l'alchimie de l'âge du silicium

Hors ligne

 

#20 2014-11-07 10:01:36 Re : v4l2 FFMPEG loopback et autres petits soucis

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 178

Re: v4l2 FFMPEG loopback et autres petits soucis



Bonjour Sakramh,

Oui, j'ai bien visité ton lien, et la doc de ffmpeg entre autres...

J'ai des soucis avec les "options" de compilation. Par exemple, j'ai v4l2 d'installé, mais la compilation avec cette option (--enable-libv4l2) ne fonctionne pas... Pour tout dire je n'ai pas encore eu le temps de tenter beaucoup de choses...

Quand au patch, c'est ce que j'ai fais de près ou de loin (le mien est moins bien rangésmile) mais cela ne permet pas de capturer l'ensemble d'une composition vidéo répartit sur plusieurs [gemhead] si je ne m'abuse...

Cela n'empeche que chez moi, la charge processeur passe de 10% à 500% d'utilisation.... Pour autant, lorsque je regarde le monitor-system, il ne m'indique qu'un fil à 100% la plupart du temps, le reste autour de 20%...

Le fait que le systeme soit 64bits peut il influer sur ces resultats ?

Bien à vous

Dernière modification par Tepaze (2014-11-07 10:02:27)

Hors ligne

 

#21 2014-11-07 12:03:40 Re : v4l2 FFMPEG loopback et autres petits soucis

sakramh
membre
Lieu: clichy-sous-bois
Date d'inscription: 2008-12-02
Messages: 828
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



[pix_snap] sur un [gemhead] est bien gourmand en effet surtout à 25 fps mais pour une simple webcam pas plus de 20% d'un coeur .  Sur Système 64 bits moi aussi . Les ressources CPU me semblent OK mais quand à la stabilité mmh.. hmm... . D'ailleurs il y a un WARNING bien rouge dans la console à ce propos .
Quand à ffmpeg j'ai inspecté la dernière version github et un ./configure --help me dit que ... pas d'option jack ni v4l2loopback . D'où je te renvoie à ces post : http://codelab.fr/5305#p27137
gstreamer est sans doute la solution (jack v4l2 x11grab et streaming) de remplacement .
Je vais d'ailleurs me pencher sur pdgst .

Dernière modification par sakramh (2014-11-07 12:12:32)


le code est l'alchimie de l'âge du silicium

Hors ligne

 

#22 2014-11-16 22:09:07 Re : v4l2 FFMPEG loopback et autres petits soucis

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 178

Re: v4l2 FFMPEG loopback et autres petits soucis



Bon, j'ai ré-installer Ubuntu Gnome en 32 bits, histoire d'être sur que cela ne venait pas de la version 64bit, mais non... L'utilisation de pix_snap sur un core i5 M 480 @ 2.67GHz, Intel® Ironlake Mobile x86/MMX/SSE2 est impossible à 25 i/sec. L'utilisation est envisageable à 15 i/sec. Sans le pix snap, le pix_record consomme 15% de CPU...

Pas grave, je vais faire autrement. Je viens de récupérer un ordi avec un vrai carte graphique et une carte d'acquisition en usb3 de chez blackmagic. D'ailleurs si quelqu'un sait comment l'exploiter sur linux, je suis preneur (j'avoue je n'ai pas encore cherché, je ne l'ai même pas eu dans la main...)

Shakramh, j'avoue (à nouveau) que gstreamer semble puissant à souhait, mais j'avoue (encore !) aussi avoir du mal à me lancer tant cela parait être construit pour des purs programmeurs. C'est pourtant surement une bonne solution, je vais donc (ré)essayé m'y pencher. D'autant que ce n'est peut être pas plus compliqué que la compilation d'une version adapter de ffmpeg...

Bien à vous

Hors ligne

 

#23 2014-11-16 23:36:34 Re : v4l2 FFMPEG loopback et autres petits soucis

sakramh
membre
Lieu: clichy-sous-bois
Date d'inscription: 2008-12-02
Messages: 828
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



http://codelab.fr/up/capt2.png
Je ne comprends pas trop, ce patch consomme 4% d'un Intel 4 coeurs datant de 2008 sur une Debian 64 bits .
Carte graphique Radeon HD 4850 (amd/ati) tournant avec le pilote libre . Xorg n'est pas sollicité par GEM . C'est donc bien les libmesa (openGL) qui font le job . Doit y avoir des trucs qui manquent ou qui sont pas les bons sur ton système (pilote de carte graphique ? dépendances openGL ? ...)
Pour la BlackMagic Olivier a donné l'astuce qlq part ici même suite à une question sur sa compatibilité v4l2 .
J'ai par ailleurs commencé à compiler des ressources Gstreamer dans la rubrique ressources . Celles qui m'ont fait un peu avancer avec ce framework .

Dernière modification par sakramh (2014-11-21 13:01:26)


le code est l'alchimie de l'âge du silicium

Hors ligne

 

#24 2014-11-17 21:09:45 Re : v4l2 FFMPEG loopback et autres petits soucis

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 178

Re: v4l2 FFMPEG loopback et autres petits soucis



VICTOIRE !!!!!!

Merci Sakramh d'avoir insisté !!!

J'ai utilisé l'utilitaire d'Intel pour installer les pilotes adéquat, comme indiqué sur cette page :
doc.ubuntu-fr.org/intel_graphics

Et depuis, je suis passé de 550% à 40% d'utilisation du CPU :-) lors de l'utilisation de pix_snap ET pix_record :-)

trop cool !

Bon, par contre pd-extended ne charge plus les png depuis que je suis en 32 bits. Ca n'a rien à voir je sais, mais j'ai installer imagemagick, vlc et gimp, histoire d'avoir les librairies png, mais toujours rien...

Une idée ? big_smile

Hors ligne

 

#25 2014-11-17 22:54:03 Re : v4l2 FFMPEG loopback et autres petits soucis

sakramh
membre
Lieu: clichy-sous-bois
Date d'inscription: 2008-12-02
Messages: 828
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



40% d'un coeur ou du i5 ? dans les deux cas çà me paraît encore beaucoup sauf si tu utilises une résolution genre HD et/ou si ton patch est bien plus complexe que ci dessus  .
Dans la console Pd j'ai Image loading support: magick SGI jpeg tiff quand je crée un [pix_image]
Me suis jamais vraiment penché sur la question ( j'utilise un paquet tout fait de pd-extended ) mais il y a peut-être une option de compilation qui a été oubliée sur la version 32 bits .... ou alors il ne reste que la couche alpha (blague) . La console te dit quoi ?
Maintenant un truc de fainéant qu'il m'est arrivé de faire dans le passé sur debian et ubuntu c'est d'intaller par synaptic Puredata et Gem (après avoir viré extended !!) pour être sûr que toutes les dépendances soient là . Puis de les désinstaller ( pd et gem, pas les dépendances lol) et de réinstaller pd-extended . J'avais pas creusé mais ce qui semblait évident c'est que le paquet en provenance de puredata.info n'était pas vraiment "debian compliant" .

Dernière modification par sakramh (2014-11-17 23:16:56)


le code est l'alchimie de l'âge du silicium

Hors ligne

 

#26 2014-11-18 08:26:25 Re : v4l2 FFMPEG loopback et autres petits soucis

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 178

Re: v4l2 FFMPEG loopback et autres petits soucis



Je ne sais pas exactement 40% de quoi. C'est la valeur donné par l'outil CPU Meter proposé via le menu de pd.Mais par rapport au 550% d'avant je trouve cela pas mal cool

Si je regarde l'activité système, cela tourne autour de 20% avec le Firefox ouvert avec une 10zaine d'onglets. A mon avis c'est 40% d'un fil.

J'utilise une résolution de 640x360.

Concernant les png, j'ai le même message que toi à peu de chose près :
Image loading support: SGI jpeg tiff

C'est une bonne idée que tu proposes. J'ai déjà essayé de ré-installer pd, mais pas comme tu le propose. Je m'en vais donc tester cela...

Bonne journée à tous.

Dernière modification par Tepaze (2014-11-18 08:27:26)

Hors ligne

 

#27 2014-11-18 12:53:27 Re : v4l2 FFMPEG loopback et autres petits soucis

sakramh
membre
Lieu: clichy-sous-bois
Date d'inscription: 2008-12-02
Messages: 828
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



citation :

Concernant les png, j'ai le même message que toi à peu de chose près :
Image loading support: SGI jpeg tiff

très à peu près en effet roll . Il manque magick qui doit être ( à peu près hmm ) tous les formats supportés par imageMagick) .
Pour ce qui est des ressources système un outil installé sur quasi tous les Unix : top et ses variantes htop etc... qui donnent la charge sur UN coeur à un instant T . htop est plus convivial mais n'est pas installé d'office et ne voit pas tjs les processus "zombie" .
Il y a hélas plein de choses à optimiser . Entre autres désactiver les effets de bureau gnome/unity qui bouffent une partie des ressources graphiques . Perso je bosse avec un kernel-RT qui répartit les priorités de manière plus efficace ( -7 pour pd-extended) ET un environnement moins gourmand : xfce .

Dernière modification par sakramh (2014-11-18 19:22:54)


le code est l'alchimie de l'âge du silicium

Hors ligne

 

#28 2014-11-19 11:06:00 Re : v4l2 FFMPEG loopback et autres petits soucis

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 178

Re: v4l2 FFMPEG loopback et autres petits soucis



Arf....

C'est reglé. J'ai le support de imagemagick à présent. J'ai fais comme tu le proposais, c'est à dire d'installer toutes les dépendances avec pure data puis de ré-installer pd-extend.

Par ailleurs j'ai compilé une version statique de ffmpeg avec le support de Jack et de v4l2 (et par la consequence v4l2loopback)

Pour ce faire j'ai installé l'ensemble des dépendances que je voulais utiliser, et suivi le guide de compilation issue du site de ffmpeg :https://trac.ffmpeg.org/wiki/CompilationGuide/Ubuntu

Ensuite, j'ai modifié la commande ./configure comme suit :

PATH="$HOME/bin:$PATH" PKG_CONFIG_PATH="$HOME/ffmpeg_build/lib/pkgconfig" ./configure   --prefix="$HOME/ffmpeg_build"\
 --extra-cflags="-I$HOME/ffmpeg_build/include"  --extra-ldflags="-L$HOME/ffmpeg_build/lib" \
 --bindir="$HOME/bin"  --enable-gpl  --enable-libass  --enable-libfdk-aac  --enable-libfreetype \
 --enable-libmp3lame  --enable-libopus  --enable-libtheora  --enable-libvorbis  --enable-libvpx \
 --enable-libx264  --enable-nonfree  --enable-libv4l2  --enable-x11grab  --enable-libdc1394 \
 --enable-libiec61883  --enable-libpulse  --enable-static  --disable-shared  --enable-gray

Ca avance , ça avance... smile

Dernière modification par Tepaze (2014-11-19 18:22:07)

Hors ligne

 

#29 2014-11-19 11:56:28 Re : v4l2 FFMPEG loopback et autres petits soucis

Olivier
N°4
Lieu: Chalon sur la Saône
Date d'inscription: 2009-04-07
Messages: 1471
Site web

Re: v4l2 FFMPEG loopback et autres petits soucis



citation :

Par ailleurs j'ai compilé une version statique de ffmpeg avec le support de Jack et de v4l2

Chouette. smile

En plus de la procédure que tu as déjà donnée, te serait-il possible de poster ton binaire dans un coin du net en précisant ton OS et ton architecture, s'il te plaît ?

Merci. smile


L'Amour au Peuple !

Hors ligne

 

#30 2014-11-19 14:39:16 Re : v4l2 FFMPEG loopback et autres petits soucis

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 178

Re: v4l2 FFMPEG loopback et autres petits soucis



Votre demande à bien été prise en compte, merci de bien vouloir patienter, un conseiller va vous répondre tongue

Avec plaisir :
http://tepaze.com/ffmpeg/

Vérifie que cela fonctionne wink C'est une 1ère...

Hors ligne

 

fil rss de cette discussion : rss

Pied de page des forums

Powered by FluxBB

codelab, graphisme & code : emoc / 2008-2017