Annonce

>>> Bienvenue sur codelab! >>> Première visite ? >>> quelques mots sur codelab //// partage de liens //// une carte des membres//// (apéros) codelab


#1 2016-09-19 16:59:08 Pd.0.47 : installation multiplateforme de bibiothèques ?

jerome
membre
Date d'inscription: 2008-03-04
Messages: 99
Site web

Pd.0.47 : installation multiplateforme de bibiothèques ?



Comme vous devez le savoir, Pd-extended est mort. Cette distribution de Pd permettait d'avoir accès à la plupart des objets, et ce pour Mac, Windows, Linux. Depuis c'est la galère. Le projet Pd-2Lork avance bien mais n'est accessible que sur Linux et n'est pas encore très stable..

La nouvelle version "vanilla" de Pd (pd.0.47) intègre dorénavant un outil multiplateforme appelé Deken qui permet de télécharger et d'installer les bibliothèques externes, notamment celles d'"Extended". C'est une belle avancée !

Mais encore faut il que les personnes sachent le nom de la librairie de l'objet voulu et que l'installation fonctionne sans autres manipulations ... Encore de quoi éloigner les personnes qui souhaitent programmer avec Pd.

Ce qui serait idéal serait de trouver un moyen d'installer Pd.0.47 pour chaque plateforme et les objets additionnels en les choisissant avec un simple clic, soit sous forme de script, soit sous forme de page Web (avec checkbox). Sur cette page Web, un outil de recherche pourrait trouver les objets dont nous avons besoin (comme sur ce pdf http://reso-nance.org/wiki/_media/logic … bjects.pdf)

Auriez-vous des pistes pour réaliser un tel outil ?

Hors ligne

 

#2 2016-10-16 15:30:06 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

geeko
membre
Date d'inscription: 2009-11-23
Messages: 106

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



c'est assez galère d'installer les lib externes sur mac avec Pd 47, je serais très reconnaissant si quelqu'un pouvait faire ce dont tu parles !

Hors ligne

 

#3 2016-10-17 09:30:29 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

nononononono
membre
Lieu: Toulouse
Date d'inscription: 2011-02-04
Messages: 601

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



hello,
pour une utilisation perso, je prends tous les externals de pd-extended que j'utilise, et je met un declare dans le main patch qui reprends les libs comme j'avais l'habitude de les utiliser sous extended....

Hors ligne

 

#4 2016-10-17 11:29:39 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

Simon Strueux
membre
Date d'inscription: 2016-07-06
Messages: 33

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



c curieux
sous Linux je tape le nom de la librairie et elle s'installe.
Quel est votre process sous MAC ?

Hors ligne

 

#5 2016-10-17 20:42:27 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

nononononono
membre
Lieu: Toulouse
Date d'inscription: 2011-02-04
Messages: 601

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



C'est exactement la même chose smile

Hors ligne

 

#6 2016-10-18 15:44:16 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

geeko
membre
Date d'inscription: 2009-11-23
Messages: 106

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



bah sur mac lorsque j'installe Gem via Deken, il fait bien le processing, il affiche les pourcentages, mais il ne fonctionne pas ...

Hors ligne

 

#7 2016-10-18 22:26:27 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

Tepaze
membre
Lieu: Angers
Date d'inscription: 2014-04-14
Messages: 173

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



Je crois qu'il est nécessaire de référencer les éléments installer via deken dans les préférences.
Le plus pratique étant d'utiliser un declare comme dit plus haut par nonononono.

Hors ligne

 

#8 2016-10-19 07:48:56 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

nononononono
membre
Lieu: Toulouse
Date d'inscription: 2011-02-04
Messages: 601

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



Pour utiliser Gem avec Decken, faut l'installer, puis mettre l'objet [Gem] comme si on faisait un declare.
Chez moi cela marche.
++

Hors ligne

 

#9 2016-10-23 01:07:02 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

jerome
membre
Date d'inscription: 2008-03-04
Messages: 99
Site web

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



Il y a deux choses :
- le téléchargement des bibliothèques et leurs copies dans le bon répertoire
- la déclaration de ces nouveaux chemins

L'importation des bibliothèques via [declare] marche effectivement. Mais pour les mettre de façon fixe, il faut donc se taper de copier tous les chemins un à un ou éditer le fichier de "settings" à la main. Pas pratique du tout. De plus il y a un nouveau comportement à [declare] qui est très gênant. Par exemple pour la Malinette, avant j'importais une abstraction qui avait à l'intérieur un declare spécifique à la Malinette, c'était bien comme méthode. Mais cela ne fonctionne plus avec pd0.47 ! Les chemins du declare ne se répercutent pas sur le patch parent...

Cela ne résoud pas le problème d'installer 15 ou 20 bibliothèques pour retrouver les fonctionnalités de l'ancien pd-extended. Deken doit être un script tcl. Si ça se trouve, dans Pd, on peut faire un bouton TCL/TK pour installer toute une liste de bibliothèques, genre "Passer en extended". Enfin même en script ce serait parfait.

Voir deken:
https://raw.githubusercontent.com/pure- … plugin.tcl

Hors ligne

 

#10 2016-11-08 17:09:17 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

MADMIND
nouveau membre
Date d'inscription: 2016-11-07
Messages: 3

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



Sujet intéressant et très utile car effectivement si de bonnes âmes peuvent mettre ça en place, cela simplifierait énormément l'instal' et la lisibilité...je suis en train de repasser de max à PD et c'est plutôt décourageant de voir que je viens de passer une journée et demi à comprendre quelle version correspondait à quoi et de quelle lib j'avais besoin pour retrouver les fonctionnalités d'extended que j'utilisais auparavant.

Je viens de me confronter au problème dont tu parlais en préambule Jérémy, à savoir : à quelle lib correspond quel objet. En l’occurrence, dans quelle librairie puis-je trouver l'objet grid via deken ?

Merci beaucoup à la communauté PD et j'ai hâte d'avoir la version Pd-2Lork osx débugué entre les mains big_smile !

Hors ligne

 

#11 2016-12-04 21:11:08 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

jojo-monk
nouveau membre
Date d'inscription: 2016-12-04
Messages: 7

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



Bonjour à tous,

J'essaye déséspérement d'installer pd0.47 et les librairies gem, cyclone etc... afin d'avoir l'équivalent de Pd extended sous mac.
J'essaye avec l'outil intégré, mais je ne sais pas quels fichiers choisir...
De plus lorsque je choisis un fichier, il se télécharge bien, mais ensuite lorsque je relance pd, j'ai un message du genre : can't load Library.

j'ai beau renseigner les startup, ça ne marche pas...

Si quelqu'un peut m'aider, ou me fournir un tuto simple ?

Merci de votre aide

Hors ligne

 

#12 2017-01-27 19:22:33 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

TomObey
membre
Date d'inscription: 2012-11-06
Messages: 110

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



Bonjour,

Je suis sur Mac, viens d'abandonner Extended pour Vanilla 0.47, et j'ai le même problème.

Exemple : Je veux utiliser readanysf~
Je le cherche via "Help/Find Externals" -> il ne le trouve pas
Je le télécharge via le site officiel, et le met dans le répertoire /Library/Pd --> Ca ne fonctionne pas
J'ajoute le dossier "/Library/Pd" dans les préferences --> toujours rien
J'essaye en ajoutant l'objet [delcare -patch readanysf~] --> toujours rien

Je ne comprend pas bien. Je pense avoir loupé quelque chose.
Qulequ'un aurait la bonté de m'expliquer la démarche exacte à suivre ?

Hors ligne

 

#13 2017-01-27 19:38:56 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

TomObey
membre
Date d'inscription: 2012-11-06
Messages: 110

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



A contrario, si j'installe la Cyclone (que je trouve dans "Help/Find externals") via Pure Data, ça fonctionne...
Mais je ne trouve pas tous mes library dans le dit menu sad

Hors ligne

 

#14 2017-01-27 19:45:00 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

jojo-monk
nouveau membre
Date d'inscription: 2016-12-04
Messages: 7

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



en fait il faut déclarer chaque dossier dans path. Par ex : /Library/Pd/cyclone si on met uniquement /Library/Pd ça ne fonctionne pas.

Hors ligne

 

#15 2017-01-27 19:49:28 Re : Pd.0.47 : installation multiplateforme de bibiothèques ?

TomObey
membre
Date d'inscription: 2012-11-06
Messages: 110

Re: Pd.0.47 : installation multiplateforme de bibiothèques ?



Pourtant, en ayant installé cyclone via le menu help, il fonctionne mais son chemin n'apparait pas dans les préférences Path.

Aussi, en ajoutant le dossier  "/Library/Pd/readanysf~" dans les préférences Path, ça ne fonctionne toujours pas.

Hors ligne

 

fil rss de cette discussion : rss

Pied de page des forums

Powered by FluxBB

codelab, graphisme & code : emoc / 2008-2017