Annonce

>>> Bienvenue sur codelab! >>> Première visite ? >>> quelques mots sur codelab //// une carte des membres//// (apéros) codelab

17 mai 2019 : accident de la base de données : plus d'infos

#1 2008-06-05 09:59:11 Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

amundsen
membre
Date d'inscription: 2008-06-05
Messages: 19

Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



Bonjour,

J'ai installé la version 0.39.3 de pd-extended sur MacOS X/MacIntel 10.4.11.

J'ai deux problèmes:

1. Librairies non chargées au démarrage:
pdp: can't load library
pidip: can't load library

2. Lorsque j'ouvre des fichiers-exemples de pmpd, j'ai des messages "coulnd't create" pour chaque objet pmpd.

Quelqu'un a une idée de solution?

Merci d'avance.

Dernière modification par amundsen (2008-06-05 10:00:47)

Hors ligne

 

#2 2008-06-05 10:24:09 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

rep
modérateur
Lieu: Toulouse
Date d'inscription: 2008-02-27
Messages: 1431
Site web

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



salut,
ben déja tu peux essayer d'instaler la nouvelle verison de pd-extended (la 0.40.3) qui est sortie hier, tu la trouveras dans la section 'Pd extended test Release' :
http://at.or.at/hans/pd/installers.html
elle apporte pas mal de nouveautés notamment dans l'interface, donc...
et pour ton problème de bibliothèque qui ne se charge pas au démarrage c'est surement parce que tu n'as pas renseigné les chemins d'accés ou le chargement de la bibliothèque dans les préférences (respectivement file/path et file/startup)

Hors ligne

 

#3 2008-06-05 11:03:39 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

amundsen
membre
Date d'inscription: 2008-06-05
Messages: 19

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



Eh bien j'ai essayé la 0.40.3 de même  que la latest-build et ce n'est pas mieux! :-((

Hors ligne

 

#4 2008-06-05 14:10:44 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

rep
modérateur
Lieu: Toulouse
Date d'inscription: 2008-02-27
Messages: 1431
Site web

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



t'es tu assuré que ces bibliothèques faisaient bien parties des bibliothèques chargées au démarrage de pd ?
t'es tu assuré que les chemins vers ces bibliothèques étaient bien renseignés ?
(sous linux le fichier à éditer/vérifier est ~/.pdsettings sous osx c'est certainement différent les mac users ici présent te renseigneront mieux que moi...)
si tu es sur à 100% que la réponse aux 2 questions précédentes est affirmative alors tu peux remplir un bug report en cliquant sur 'report a bug' dans le menu Help... mais cela m'étonnerait que ce soit le cas, car ce que tu décris est un problème commun et récurrent aux personnes débutantes sous puredata et qui parfois ont un peu de mal à charger correctement une bibiliothèque au lancement de pd...

Hors ligne

 

#5 2008-06-06 10:22:56 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

amundsen
membre
Date d'inscription: 2008-06-05
Messages: 19

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



rep a écrit:

t'es tu assuré que ces bibliothèques faisaient bien parties des bibliothèques chargées au démarrage de pd ?
t'es tu assuré que les chemins vers ces bibliothèques étaient bien renseignés ?
(sous linux le fichier à éditer/vérifier est ~/.pdsettings sous osx c'est certainement différent les mac users ici présent te renseigneront mieux que moi...)

Apparemment pmpd est en réalité bel et bien chargé. Le problème vient des exemples, qui recourent à des alias qui ne fonctionnent pas (est-ce lié à la version MacOS X de Pure Data ou de pmpd?). En remplaçant ces alias par des noms d'objets "réels" (ex: lia -> link; masse2D -> mass2D, etc), pmpd fonctionne.

MAIS beaucoup d'exemples de pmpd nécessitent aussi Gem, qui est bel et bien installé. Or Gem ne fonctionne pas. Se pourrait-il que ce soit parce que pdp et/ou pidip ne sont pas chargés?

J'ai bien vérifié les chemins dans les préférences, ils correspondent bien aux chemins réels. Mais alors pourquoi est-ce que cela ne fonctionne pas?

Hors ligne

 

#6 2008-06-06 10:36:18 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

oli44
membre
Lieu: Notre Dame des Landes
Date d'inscription: 2008-04-25
Messages: 585
Site web

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



Oui il y a pas mal de problèmes de liens vers la doc depuis quelques semaines dans les dernières test releases. jette un oeil dans les bug reports sur sourceforge:

http://sourceforge.net/tracker/?group_i … tid=478070

Non Gem ne fonctionnera pas mieux ou moins bien si PDP/PIdip est chargé.


La route est longue mais la voie est libre

Hors ligne

 

#7 2008-06-06 10:41:10 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

amundsen
membre
Date d'inscription: 2008-06-05
Messages: 19

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



Bon, je pense avoir compris: Sur MacOS X, il faut que X11 soit installé pour que Pd fonctionne bien. J'ai compris cela suite aux messages d'erreur ("/Applications/Pd-extended 0.40.3.app/Contents/Resources/extra/Gem.pd_darwin: dlopen(/Applications/Pd-extended 0.40.3.app/Contents/Resources/extra/Gem.pd_darwin, 10): Library not loaded: /usr/X11R6/lib/libfreetype.6.dylib") et en lisant quelques messages sur le forum anglophone.

Donc, je télécharge la chose (site Apple) et je vous tiens au courant.


Ben non, pour Tiger X11 (version 1.2) n'est pas disponible en téléchargement, à moins d'installer tous les outils développeur. Il suffit de retrouver les DVD d'installation de Tiger et X11 est dessus.

Dernière modification par amundsen (2008-06-06 10:50:00)

Hors ligne

 

#8 2008-06-06 11:24:55 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

amundsen
membre
Date d'inscription: 2008-06-05
Messages: 19

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



Eh bien voilà, X11 est installé et tout fonctionne bien (quoique le problème des alias subsiste).

Enjoy!

Hors ligne

 

#9 2008-06-06 19:49:13 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

rep
modérateur
Lieu: Toulouse
Date d'inscription: 2008-02-27
Messages: 1431
Site web

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



amundsen a écrit:

Eh bien voilà, X11 est installé et tout fonctionne bien

ha ben voila! content que ça fonctionne!!

amundsen a écrit:

quoique le problème des alias subsiste

sur pd-extended les alias ne fonctionne pas
il faut nommer les objets dans ler version longue

Hors ligne

 

#10 2008-06-06 22:39:33 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

oli44
membre
Lieu: Notre Dame des Landes
Date d'inscription: 2008-04-25
Messages: 585
Site web

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



Il vient d'y avoir unposte sur la pd-list d'un autre utuilisateur Windows qui disait qu'uacun des fichiers d'aide de Gem de Pd extedned ne marche.

Ce doit être un bug.

++
O.


La route est longue mais la voie est libre

Hors ligne

 

#11 2008-06-09 10:32:57 Re : Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel

amundsen
membre
Date d'inscription: 2008-06-05
Messages: 19

Re: Problème de librairies avec pd-extended 0.39.3 sur MacOSX/Intel



Je confirme ce problème avec les fichiers d'aide de Gem dans pd-extended 0.40.3 sur MacIntel.

Hors ligne

 

fil rss de cette discussion : rss

Pied de page des forums

Powered by FluxBB

codelab, graphisme & code : emoc / 2008-2020